AAS Updates Tassman and Lounge Lizard

Applied Acoustics Systems has updated Tassman 4 and Lounge Lizard EP-2 to be compatible with the AU validation test of Logic 7. These service updates are free of charge for all Tassman 4 and Lounge Lizard EP-2 users and can be from the Applied Acoustics site:

Tassman 4 AU Plug-In Update

Lounge Lizard EP-2 AU Plug-In Update

Leave a Reply