DUY Releases Intel-Compatible TDM Plug-ins

duy logoDUY has announced that the entire range of TDM plug-ins is now compatible with Apple’s Intel-based Mac computers, in addition to the recently-released native-compatible versions.

Registered users have been informed by email of the updated links to download the new versions. The available demo versions being delivered through DUY’s website are also Intel-compatible.

DUY’s Universal Binary versions are 4.0 for all TDM plug-ins except for Magic Spectrum PRO (2.0), MagicEQ (2.0) and SynthSpider (3.0).

Registered users who already had an iLok license of the software can download this update for free and use the same iLok license. Users who don’t have an iLok-compatible version of the software will have to upgrade to the latest version.

The availability of these new Intel-compatible versions comes as an addition to the recently announced compatibility for RTAS, Audio Units, VST and MAS versions, providing full compatibility with Apple’s new processors for the entire range of DUY plug-ins.

Mac OSX 10.3.9 or higher is required to run the Intel-compatible versions. Mac OSX 10.2 or higher required for the non-Intel (PPC) versions.

Leave a Reply